Translate (translate.apache.org) is down!
Incident Report for Apache Software Foundation
Resolved
This incident has been resolved. To view history or postmortem please visit https://status.apache.org/#past-incidents
Posted 4 days ago. Dec 06, 2018 - 18:23 UTC
Investigating
Translate (translate.apache.org) is down!
Posted 4 days ago. Dec 06, 2018 - 18:09 UTC
This incident affected: Internal Infrastructure Services (Infra On Call).