Translate is down!
Incident Report for Apache Software Foundation
Resolved
This incident has been resolved. To view history or postmortem please visit
Posted Jun 15, 2018 - 02:38 UTC
Update
We've acknowledged that Translate is down! Infra is on the case.
Posted Jun 15, 2018 - 02:08 UTC
Update
We've acknowledged that Translate is down! Infra is on the case.
Posted Jun 15, 2018 - 02:08 UTC
Investigating
Translate is down!
Posted Jun 15, 2018 - 02:06 UTC