repository.apache.org degraded performance

Incident Report for Apache Software Foundation

Identified

Infra has identified the underlying cause of the performance issue as a hardware problem and is in the process of migrating data to a replacement server.
Posted Jun 02, 2025 - 00:28 UTC

Update

We are continuing to investigate the issue, and are working with our hosting provider to replace the hardware.
Posted May 29, 2025 - 16:59 UTC

Investigating

repository.apache.org is suffering from degraded performance, causing 408 errors and slowness in synchronization to Maven Central. Infra is investigating.
Posted May 28, 2025 - 17:41 UTC
This incident affects: Internal Services (Build Services (Jenkins, Buildbot, etc)).