Apache Distribution (dist.apache.org) is experiencing issues.

Incident Report for Apache Software Foundation

Resolved

Apache Distribution (dist.apache.org) has resumed normal operation. To view history or postmortem please visit https://status.apache.org/#past-incidents
Posted Mar 14, 2025 - 13:18 UTC

Update

Infra has acknowledged downtime on Apache Distribution (dist.apache.org) and is investigating.
Posted Mar 14, 2025 - 12:23 UTC

Update

Infra has acknowledged downtime on Apache Distribution (dist.apache.org) and is investigating.
Posted Mar 14, 2025 - 12:02 UTC

Investigating

Apache Distribution (dist.apache.org) is experiencing issues.
Posted Mar 14, 2025 - 10:01 UTC
This incident affected: Internal Services (Infra On Call).