Nexus (repository.apache.org) Degraded Performance
Incident Report for Apache Software Foundation
Resolved
This incident has been resolved.
Posted May 11, 2020 - 19:01 UTC
Investigating
repository.apache.org is experiencing significant performance degredation.
Posted May 11, 2020 - 17:37 UTC
This incident affected: Internal Infrastructure Services (Infra On Call).