ASF Committer Email Certificate is partially untrusted

Incident Report for Apache Software Foundation

Resolved

The certificate chain issue has been resolved.
Posted Sep 18, 2025 - 23:58 UTC

Investigating

Affecting some ASF Committers. A new certificate for our mail system was renewed, and we are investigating reported issues for a few people.
Posted Sep 18, 2025 - 17:48 UTC
This incident affected: Internal Services (Mail Services - apache.org).