lists.apache.org slow to respond

Incident Report for Apache Software Foundation

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 19:49 UTC

Investigating

We are currently investigating this issue.
Posted Mar 17, 2026 - 10:25 UTC
This incident affected: Internal Services (Mail Services - apache.org).