Mail - Mail Delivery Delay is experiencing issues.
Incident Report for Apache Software Foundation
Resolved
Mail - Mail Delivery Delay has resumed normal operation. To view history or postmortem please visit https://status.apache.org/#past-incidents
Posted Mar 02, 2021 - 12:14 UTC
Update
Infra has acknowledged downtime on Mail - Mail Delivery Delay and is investigating.
Posted Mar 02, 2021 - 11:19 UTC
Investigating
Mail - Mail Delivery Delay is experiencing issues.
Posted Mar 02, 2021 - 11:19 UTC
This incident affected: Internal Services (Infra On Call).