downloads.apache.org is experiencing issues.
Incident Report for Apache Software Foundation
Resolved
downloads.apache.org has resumed normal operation. To view history or postmortem please visit https://status.apache.org/#past-incidents
Posted Sep 14, 2020 - 09:51 UTC
Update
Infra has acknowledged downtime on downloads.apache.org and is investigating.
Posted Sep 14, 2020 - 09:46 UTC
Investigating
downloads.apache.org is experiencing issues.
Posted Sep 14, 2020 - 09:45 UTC
This incident affected: Internal Infrastructure Services (Infra On Call).