Email infrastructure downtime
Incident Report for Apache Software Foundation
Resolved
The issues have been resolved by our data center and things should be back to normal.
Expect some delays in email delivery as the services catch up.
Posted May 25, 2020 - 14:38 UTC
Identified
Our email infrastructure is currently experiencing downtime due to unforeseen issues at one of our data centers. The issues have been identified and the data center is working on restoring the service. We expect operations to resume within the hour.
Posted May 25, 2020 - 14:13 UTC
This incident affected: Internal Services (General Issues).